软件开发架构师

一行代码迁移TensorFlow 1.x到TensorFlow 2.0

人工智能 15 2019-03-11 11:10

TensorFlow 2.0 将会包含许多 API 改变,例如改变参数顺序、重命名、修改默认值等。手动迁移代码比较繁琐,还有出错的风险。为了让你的老代码能够向 TensorFlow 2.0 无缝迁移,TensorFlow 开发组推出了 tf_upgrade_v2 功能。

当你使用 pip 安装 TensorFlow 2.0 时,tf_upgrade_v2 就会自动安装,它可以帮你更快速地将已有的 TensorFlow 1.13 脚本迁移到 TensorFlow 2.0。

我们尝试尽可能多地自动执行升级任务:但是,仍然有一些句法和风格改变是 tf_upgrade_v2 无法自动迁移的,这些变更无法用简单的字符串替换来实现。为了确保你的代码可以被 TensorFlow 2.0 支持,升级脚本中包含了一个 compat.v1 模块。这个模块会将 tf.foo 形式的调用替换为 tf.compat.v1.foo。我们推荐的做法是,尽快人工校对这些替换,并将它们迁移到 tf.* 命名空间下的新 API 而不是使用 tf.compat.v1.* 命名空间。

另外,由于一些模块被废弃(例如 tf.flags 和 tf.contrib),TensorFlow 2.0 会包含一些无法通过切换到 compat.v1 解决的变更。升级这些代码需要用到额外的库(如 absl.flags)或者将代码切换到 tensorflow/addons 包下。

如果你想要把模型从 TensorFlow 1.12 迁移到 TensorFlow 2.0,首先要安装 tf-nightly-2.0-preview 或 tf-nightly-gpu-2.0-preview。

然后就可以通过运行一个单独的 Python 脚本直接升级:

复制代码
tf_upgrade_v2 — infile foo .py — outfile foo-upgraded .py

image

注意:通过 pip install 安装 TensorFlow 1.13 及后续版本时会自动安装 tf_upgrade_v2。

也可以在文件夹目录中执行升级脚本:

复制代码
# upgrade the .py files and copy all the other files to the outtree
tf_upgrade_v2 — intree foo / — outtree foo-upgraded/
# just upgrade the .py files
tf_upgrade_v2 — intree foo / — outtree foo-upgraded/ — copyotherfiles False

脚本会列出到底做了哪些改动,例如参数重命名:

image

添加关键字:

image

以及有哪些地方推荐进行人工检查:

image

所有的信息都会被包含在当前文件夹的 report.txt 中。升级完成后,你可以运行模型来检查你的输出是否和 1.13 版本的输出相似。

警告

  • 在运行脚本之前,不要手动修改代码。尤其是那些会变更参数顺序的函数,例如 tf.argmax 或者 tf.batch_to_space,这会导致脚本错误地映射参数关键词。

  • 脚本本身不会进行参数重排序,只会为发生了参数重排的函数添加参数关键字

参考链接:
https://medium.com/tensorflow/upgrading-your-code-to-tensorflow-2-0-f72c3a4d83b5

更多内容,请关注 AI 前线

image

文章评论